[BZOJ4562] [Haoi2016]食物链

题目描述

Description

如图所示为某生态系统的食物网示意图,据图回答第1小题
现在给你n个物种和m条能量流动关系,求其中的食物链条数。
物种的名称为从1到n编号
M条能量流动关系形如
a1 b1
a2 b2
a3 b3
......
am-1 bm-1
am bm
其中ai bi表示能量从物种ai流向物种bi,注意单独的一种孤立生物不算一条食物链

Input

第一行两个整数n和m,接下来m行每行两个整数ai bi描述m条能量流动关系。
(数据保证输入数据符号生物学特点,且不会有重复的能量流动关系出现)
1<=N<=100000 0<=m<=200000
题目保证答案不会爆 int

Output

一个整数即食物网中的食物链条数

Sample Input

10 16
1 2
1 4
1 10
2 3
2 5
4 3
4 5
4 8
6 5
7 6
7 9
8 5
9 8
10 6
10 7
10 9

Sample Output


9

题目分析

题目大意:给定你一个DAG图,求任意一条从入度为0的点到出度为0的点的方案数,其中不包括入度和出度都为0的点
然后进行拓扑排序转移方案数即可

#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <algorithm>
using namespace std;
int n,m;
int head[101000],net[440000],to[440000],ru[101000],chu[101000];
int tot;
void add(int x,int y)
{
    net[++tot]=head[x];
    to[tot]=y;
    head[x]=tot;
}
int f[101000],ruu[101000];
void topsort()
{
    queue<int>q;
    for(int i=1;i<=n;i++)
        if(!ru[i]) q.push(i),f[i]=1;
    while(q.size())
    {
        int nmp=q.front();
        q.pop();
        for(int i=head[nmp];i;i=net[i])
        {
            ru[to[i]]--;
            f[to[i]]+=f[nmp];
            if(!ru[to[i]]) q.push(to[i]);
        }
    }
    int ans=0;
    for(int i=1;i<=n;i++)
        if(!chu[i]&&ruu[i]) ans+=f[i];
    printf("%d",ans);
}
int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;i++)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        add(x,y),chu[x]++,ru[y]++,ruu[y]++;
    }
    topsort();
}

发表评论

邮箱地址不会被公开。 必填项已用*标注