[BZOJ1531] [POI2005]Bank notes

题目描述

Description

Byteotian Bit Bank (BBB) 拥有一套先进的货币系统,这个系统一共有n种面值的硬币,面值分别为b1, b2,..., bn. 但是每种硬币有数量限制,现在我们想要凑出面值k求最少要用多少个硬币.

Input

第一行一个数 n, 1 <= n <= 200. 接下来一行 n 个整数b1, b2,..., bn, 1 <= b1 < b2 < ... < b n <= 20 000, 第三行 n 个整数c1, c2,..., cn, 1 <= ci <= 20 000, 表示每种硬币的个数.最后一行一个数k – 表示要凑的面值数量, 1 <= k <= 20 000.

Output

第一行一个数表示最少需要付的硬币数

Sample Input

3
2 3 5
2 2 1
10

Sample Output

3

题目分析

分组背包 因为直接枚举c[i]会TLE 所以二进制拆分

#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <algorithm>
using namespace std;
int f[201010];
int n,m;
int b[20010],c[20010];
void one(int w,int c)
{
    for(int i=m;i>=w;i--)
        f[i]=min(f[i],f[i-w]+c);
}
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++) scanf("%d",&b[i]);
    for(int i=1;i<=n;i++) scanf("%d",&c[i]);
    scanf("%d",&m);
    memset(f,0x3f,sizeof f);
    f[0]=0;
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=c[i];j<<=1)
            one(b[i]*j,j),c[i]-=j;
        if(c[i]) one(b[i]*c[i],c[i]);
    }
    printf("%d",f[m]);
    return 0;
}

发表评论

邮箱地址不会被公开。 必填项已用*标注