[BZOJ1334] [Baltic2008]Elect

题目描述

Description

N个政党要组成一个联合内阁,每个党都有自己的席位数. 现在希望你找出一种方案,你选中的党的席位数要大于总数的一半,并且联合内阁的席位数越多越好. 对于一个联合内阁,如果某个政党退出后,其它党的席位仍大于总数的一半,则这个政党被称为是多余的,这是不允许的.

Input

第一行给出有多少个政党.其值小于等于300 下面给出每个政党的席位数.总席位数小于等于 100000

Output

你的组阁方案中最多能占多少个席位.

Sample Input

4
1 3 2 4

Sample Output

7

HINT

选择第二个政党和第四个

题目分析

一开始理解错了题意 以为总和指的是最终选出来的总和= =
那么直接就01背包转移即可
注意:从sum(总和)/2+a[i]->a[i]

#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <algorithm>
using namespace std;
int n,sum,ans;
int a[100100],f[100100];
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++) scanf("%d",&a[i]),sum+=a[i];
    sort(a+1,a+n+1);
    f[0]=1;
    for(int i=n;i>=1;i--)
        for(int j=sum/2+a[i];j>=a[i];j--)
            if(f[j-a[i]]) f[j]=1,ans=max(j,ans);
    printf("%d",ans);
    return 0;
}

发表评论

邮箱地址不会被公开。 必填项已用*标注