POJ3249 Test for Job

Description

Mr.Dog was fired by his company. In order to support his family, he must find a new job as soon as possible. Nowadays, It's hard to have a job, since there are swelling numbers of the unemployed. So some companies often use hard tests for their recruitment.

The test is like this: starting from a source-city, you may pass through some directed roads to reach another city. Each time you reach a city, you can earn some profit or pay some fee, Let this process continue until you reach a target-city. The boss will compute the expense you spent for your trip and the profit you have just obtained. Finally, he will decide whether you can be hired.

In order to get the job, Mr.Dog managed to obtain the knowledge of the net profit Vi of all cities he may reach (a negative Vi indicates that money is spent rather than gained) and the connection between cities. A city with no roads leading to it is a source-city and a city with no roads leading to other cities is a target-city. The mission of Mr.Dog is to start from a source-city and choose a route leading to a target-city through which he can get the maximum profit.

Input

The input file includes several test cases.
The first line of each test case contains 2 integers n and m(1 ≤ n ≤ 100000, 0 ≤ m ≤ 1000000) indicating the number of cities and roads.
The next n lines each contain a single integer. The ith line describes the net profit of the city i, Vi (0 ≤ |Vi| ≤ 20000)
The next m lines each contain two integers x, y indicating that there is a road leads from city x to city y. It is guaranteed that each road appears exactly once, and there is no way to return to a previous city.

Output

The output file contains one line for each test cases, in which contains an integer indicating the maximum profit Dog is able to obtain (or the minimum expenditure to spend)

Sample Input

6 5
1
2
2
3
3
4
1 2
1 3
2 4
3 4
5 6

Sample Output

7

题目分析:

给出一个有向无环图,每个顶点都有一个权值。求一条从入度为0的顶点到出度为0的顶点的一条路径,路径上所有顶点权值和最大。

大水题 因为边权有负数 注意初始化为极小值

#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <algorithm>
using namespace std;
int in[100100];
int out[100100];
int n,m;
int head[100100];
int val[2200100];
int to[2200100];
int next[2200100];
int tot;
int dis[100100];
void add(int x,int y)
{
    next[++tot]=head[x];
    head[x]=tot;
    to[tot]=y;
}
void init()
{
    tot=0;
    memset(val,0,sizeof val);
    memset(head,0,sizeof head);
    memset(to,0,sizeof to);
    memset(next,0,sizeof next);
    memset(in,0,sizeof in);
    memset(out,0,sizeof out);
}
void topsort()
{
    queue<int>q;
    for(int i=1;i<=n;i++)
        if(!in[i]) q.push(i),dis[i]=val[i];
    while(q.size())
    {
        int nmp=q.front();
        q.pop();
        for(int i=head[nmp];i;i=next[i])
        {
            if(dis[to[i]]<dis[nmp]+val[to[i]])
                dis[to[i]]=dis[nmp]+val[to[i]];
            in[to[i]]--;
            if(!in[to[i]]) q.push(to[i]);
        }
    }
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        init();
        for(int i=1;i<=n;i++)
            scanf("%d",&val[i]);
        for(int i=1;i<=m;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            add(x,y);
            in[y]++;
            out[x]++;
        }
        memset(dis,-0x3f,sizeof dis);
        topsort();
        int ans=-0x3f3f3f3f;
        for(int i=1;i<=n;i++)
            if(!out[i]) ans=max(ans,dis[i]);
        printf("%d\n",ans);
    }   
    return 0;
}

发表评论

邮箱地址不会被公开。 必填项已用*标注