[BZOJ4419] [Shoi2013]发微博

题目描述

Description

刚开通的SH微博共有n个用户(1..n标号),在短短一个月的时间内,用户们活动频繁,共有m条按时间顺序的记录:
! x 表示用户x发了一条微博;
+ x y 表示用户x和用户y成为了好友
- x y 表示用户x和用户y解除了好友关系
当一个用户发微博的时候,所有他的好友(直接关系)都会看到他的消息。
假设最开始所有人之间都不是好友关系,记录也都是合法的(即+ x y时x和y一定不是好友,而- x y时x和y一定是好友)。
问这m条记录发生之后,每个用户分别看到了多少条消息。

Input

第1行2个整数n,m。
接下来m行,按时间顺序读入m条记录,每条记录的格式如题目所述,用空格隔开。

Output

输出一行n个用空格隔开的数(行末无空格),第i个数表示用户i最后看到了几条消息。

Sample Input

2 8
! 1
! 2
 + 1 2
! 1
! 2
 - 1 2
! 1
! 2

Sample Output

1 1

只有第4和第5条记录对应的消息被看到过。其他消息发送时,1和2不是好友。
对100%的数据,N<=200000,M<=500000

题目分析

用set维护水过= =
解除关系的时候直接维护信息 具体看代码

#include <cstdio>
#include <cstring>
#include <set>
#include <map>
#include <vector>
#include <cmath>
#include <queue>
#include <algorithm>
using namespace std;
int n,m;
char s[10];
set<int> a[200005];
set<int>::iterator it;
int give[200005],get[200005];
int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;i++)
    {
        scanf("%s",&s[0]);
        int x,y;
        if(s[0]=='!') scanf("%d",&x),give[x]++;
        else if(s[0]=='+') scanf("%d%d",&x,&y),a[x].insert(y),a[y].insert(x),get[x]-=give[y],get[y]-=give[x];
        else scanf("%d%d",&x,&y),get[x]+=give[y],get[y]+=give[x],a[x].erase(y),a[y].erase(x);
    }
    for(int i=1;i<=n;i++)
        for(it=a[i].begin();it!=a[i].end();it++) get[*it]+=give[i];
    for(int i=1;i<=n;i++) printf("%d%c",get[i],i==n?'\n':' ');
    return 0;
}

发表评论

邮箱地址不会被公开。 必填项已用*标注