[BZOJ3036] 绿豆蛙的归宿

Description

随着新版百度空间的下线,Blog宠物绿豆蛙完成了它的使命,去寻找它新的归宿。

给出一个有向无环的连通图,起点为1终点为N,每条边都有一个长度。绿豆蛙从起点出发,走向终点。
到达每一个顶点时,如果有K条离开该点的道路,绿豆蛙可以选择任意一条道路离开该点,并且走向每条路的概率为 1/K 。
现在绿豆蛙想知道,从起点走到终点的所经过的路径总长度期望是多少?

Input

第一行: 两个整数 N M,代表图中有N个点、M条边
第二行到第 1+M 行: 每行3个整数 a b c,代表从a到b有一条长度为c的有向边

Output

从起点到终点路径总长度的期望值,四舍五入保留两位小数。

Sample Input

4 4
1 2 1
1 3 2
2 3 3
3 4 4

Sample Output

7.00

HINT

对于100%的数据  N<=100000,M<=2*N

题目分析:

f[i] 代表从i到n的期望长度
然后dfs搞一下就可以了 记得不要除0

#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <algorithm>
using namespace std;
int n,m;
int head[200100],to[200100],net[200100],val[200100],out[200100];
bool vis[200100];
double f[200100];
int tot;
void add(int x,int y,int c)
{
	net[++tot]=head[x];
	val[tot]=c;
	to[tot]=y;
	head[x]=tot;
}
void dfs(int x)
{
	if(vis[x]) return ;
	vis[x]=1;
	for(int i=head[x];i;i=net[i])
		dfs(to[i]),f[x]+=f[to[i]]+val[i];
	if(out[x]) f[x]/=out[x];
	return ;
}
int main()
{
	scanf("%d%d",&n,&m);
	for(int i=1;i<=m;i++)
	{
		int x,y,c;
		scanf("%d%d%d",&x,&y,&c);
		add(x,y,c);
		out[x]++;
	}
	dfs(1);
	printf("%.2lf",f[1]);
    return 0;
}

发表评论

邮箱地址不会被公开。 必填项已用*标注