Description
永无乡包含 n 座岛,编号从 1 到 n,每座岛都有自己的独一无二的重要度,按照重要度可 以将这 n 座岛排名,名次用 1 到 n 来表示。某些岛之间由巨大的桥连接,通过桥可以从一个岛 到达另一个岛。如果从岛 a 出发经过若干座(含 0 座)桥可以到达岛 b,则称岛 a 和岛 b 是连 通的。现在有两种操作:B x y 表示在岛 x 与岛 y 之间修建一座新桥。Q x k 表示询问当前与岛 x连通的所有岛中第 k 重要的是哪座岛,即所有与岛 x 连通的岛中重要度排名第 k 小的岛是哪 座,请你输出那个岛的编号。
Input
输入文件第一行是用空格隔开的两个正整数 n 和 m,分别 表示岛的个数以及一开始存在的桥数。接下来的一行是用空格隔开的 n 个数,依次描述从岛 1 到岛 n 的重要度排名。随后的 m 行每行是用空格隔开的两个正整数 ai 和 bi,表示一开始就存 在一座连接岛 ai 和岛 bi 的桥。后面剩下的部分描述操作,该部分的第一行是一个正整数 q, 表示一共有 q 个操作,接下来的 q 行依次描述每个操作,操作的格式如上所述,以大写字母 Q 或B 开始,后面跟两个不超过 n 的正整数,字母与数字以及两个数字之间用空格隔开。 对于 20%的数据 n≤1000,q≤1000
对于 100%的数据 n≤100000,m≤n,q≤300000
Output
对于每个 Q x k 操作都要依次输出一行,其中包含一个整数,表 示所询问岛屿的编号。如果该岛屿不存在,则输出-1。
Sample Input
5 1
4 3 2 5 1
1 2
7
Q 3 2
Q 2 1
B 2 3
B 1 5
Q 2 1
Q 2 4
Q 2 3
Sample Output
-1
2
5
1
2
题目分析
非旋转treap启发式合并 暴力拆即可
#include <cstdio>
#include <cstring>
#include <cmath>
#include <ctime>
#include <queue>
#include <algorithm>
using namespace std;
typedef pair<int,int> par;
int n,m;
int val[101000*3],size[101000*3],key[101000*3],lson[101000*3],rson[101000*3];
int fa[101000*3];
int tot,root[101000];
inline int read()
{
char ch=getchar(); int re=0,f=1;
while(ch<'0'||ch>'9'){if(ch=='-') f=-1; ch=getchar();}
while(ch>='0'&&ch<='9')
re=(re<<1)+(re<<3)+ch-'0',ch=getchar();
return re*f;
}
void update(int x)
{
size[x]=size[lson[x]]+size[rson[x]]+1;
}
void pushdown(int x)
{
return ;
}
int merge(int x,int y)
{
pushdown(x),pushdown(y);
if(x==0||y==0) return x|y;
if(key[x]<key[y])
{
lson[y]=merge(x,lson[y]),fa[lson[y]]=y,update(y);
return y;
}
rson[x]=merge(rson[x],y),fa[rson[x]]=x,update(x);
return x;
}
par split(int x,int k)
{
if(k==0) return make_pair(0,x);
pushdown(x);
int l=lson[x],r=rson[x];
if(k==size[lson[x]])
{
lson[x]=0,update(x),fa[lson[x]]=0;
return make_pair(l,x);
}
if(k==size[lson[x]]+1)
{
rson[x]=0,update(x),fa[rson[x]]=0;
return make_pair(x,r);
}
par t;
if(k<size[lson[x]])
{
t=split(l,k);
lson[x]=t.second,fa[lson[x]]=x,update(x);
return make_pair(t.first,x);
}
else
{
t=split(r,k-size[lson[x]]-1);
rson[x]=t.first,fa[rson[x]]=x,update(x);
return make_pair(x,t.second);
}
}
int getrank(int x,int k)
{
int ans=0;
while(k)
{
if(val[k]<x) ans+=size[lson[k]]+1,k=rson[k];
else k=lson[k];
}
return ans+1;
}
int get(int x,int k)
{
while(1)
{
if(!k) return -1;
if(size[lson[k]]+1==x) return k;
if(size[lson[k]]>=x) k=lson[k];
else x-=size[lson[k]]+1,k=rson[k];
}
}
int insert(int x,int k)
{
int rank=getrank(val[x],k);
par t=split(k,rank-1);
t.first=merge(t.first,x);
return merge(t.first,t.second);
}
char s[100];
int f[100010];
int find(int x)
{
return f[x]==x?x:find(f[x]);
}
int main()
{
n=read(),m=read();
for(int i=1;i<=n;i++)
val[i]=read(),size[i]=1,key[i]=rand()*rand(),f[i]=i;
for(int i=1;i<=m;i++)
{
int x,y;
scanf("%d%d",&x,&y);
x=find(x),y=find(y);
if(x!=y) f[x]=y;
}
for(int i=1;i<=n;i++)
{
int dx=find(i);
root[dx]=insert(i,root[dx]);
}
m=read();
for(int i=1;i<=m;i++)
{
scanf("%s",&s[0]);
int x,y;
x=read(),y=read();
if(s[0]=='B')
{
x=find(x),y=find(y);
if(x==y) continue;
if(size[root[x]]<size[root[y]]) swap(x,y);
while(size[root[y]])
{
par t=split(root[y],1);
root[x]=insert(t.first,root[x]);
root[y]=t.second;
}
f[y]=x;
}
else
{
int dx=find(x);
printf("%d\n",get(y,root[dx]));
}
}
}