[BZOJ1355] [Baltic2009]Radio Transmission

Description

给你一个字符串,它是由某个字符串不断自我连接形成的。 但是这个字符串是不确定的,现在只想知道它的最短长度是多少.

Input

第一行给出字符串的长度,1 < L ≤ 1,000,000. 第二行给出一个字符串,全由小写字母组成.

Output

输出最短的长度

Sample Input

8
cabcabca

Sample Output

3

题目分析

一眼二分+hash没毛病吧 时间复杂度O(ln n)
但是这题有一个更绝妙的方法 跑一遍kmp 答案就是表示循环节的n-net[n]

#include <cstdio>
#include <cstring>
#include <set>
#include <map>
#include <vector>
#include <cmath>
#include <queue>
#include <algorithm>
using namespace std;
int len;
char s[1000010];
int net[1000010];
void getnext()
{
    net[0]=-1;
    int i=0,j=-1;
    while(i<len)
    {
        if(j==-1||s[i]==s[j])
            net[++i]=++j;
        else j=net[j];
    }
}
int main()
{   
    scanf("%d%s",&len,&s[0]);
    getnext();
    printf("%d",len-net[len]);
    return 0;
}

发表评论

邮箱地址不会被公开。 必填项已用*标注