[BZOJ1293] [SCOI2009]生日礼物

题目描述

Description

小西有一条很长的彩带,彩带上挂着各式各样的彩珠。已知彩珠有N个,分为K种。简单的说,可以将彩带考虑为x轴,每一个彩珠有一个对应的坐标(即位置)。某些坐标上可以没有彩珠,但多个彩珠也可以出现在同一个位置上。 小布生日快到了,于是小西打算剪一段彩带送给小布。为了让礼物彩带足够漂亮,小西希望这一段彩带中能包含所有种类的彩珠。同时,为了方便,小西希望这段彩带尽可能短,你能帮助小西计算这个最短的长度么?彩带的长度即为彩带开始位置到结束位置的位置差。

Input

第一行包含两个整数N, K,分别表示彩珠的总数以及种类数。接下来K行,每行第一个数为Ti,表示第i种彩珠的数目。接下来按升序给出Ti个非负整数,为这Ti个彩珠分别出现的位置。

Output

应包含一行,为最短彩带长度。

Sample Input

6 3
1 5
2 1 7
3 1 3 8

Sample Output

 

3

HINT

 

有多种方案可选,其中比较短的是1~5和5~8。后者长度为3最短。 【数据规模】 对于50%的数据, N≤10000; 对于80%的数据, N≤800000; 对于100%的数据,1≤N≤1000000,1≤K≤60,0≤彩珠位置<2^31。

题目分析:

离线位置+双指针乱搞,注意l++时要把处在同一位置的彩珠都删去,r++时同理

#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <algorithm>
using namespace std;
int cnt;
int num[100];
int n,k;
struct your
{
    int x,id;
}a[1000100];
int tot;
int cmp(your j,your k)
{
    return j.id<k.id;
}
long long ans=1000000000;
int main()
{
    scanf("%d%d",&n,&k);
    for(int i=1;i<=k;i++)
    {
        int tmp;
        scanf("%d",&tmp);
        for(int j=1;j<=tmp;j++)
        {
            int x;
            scanf("%d",&x);
            x++,tot++,a[tot].x=i,a[tot].id=x;
        }
    }
    sort(a+1,a+n+1,cmp);
    int l=1,r=0;
    for(int i=1;i<=n;)
    {
        num[a[i].x]++;
        if(num[a[i].x]==1) cnt++;
        while(i<n&&a[i].id==a[i+1].id) 
        {
            i++;
            num[a[i].x]++;
            if(num[a[i].x]==1) cnt++;
        }
        if(cnt==k)
        {
            if(ans>a[i].id-a[l].id) 
                ans=a[i].id-a[l].id;
            while(l<=i&&cnt==k)
            {
                if(ans>a[i].id-a[l].id) 
                    ans=a[i].id-a[l].id;
                num[a[l].x]--;
                if(num[a[l].x]==0) cnt--;   
                l++;
                while(l<=i&&a[l].id==a[l-1].id)
                {
                    num[a[l].x]--;
                    if(num[a[l].x]==0) cnt--;
                    l++;
                }
            }
        }
        i++;
    }
    printf("%lld",ans);
    return 0;
}

 

发表评论

邮箱地址不会被公开。 必填项已用*标注