[BZOJ1086] [SCOI2005]王室联邦

题目描述

Description

  “余”人国的国王想重新编制他的国家。他想把他的国家划分成若干个省,每个省都由他们王室联邦的一个成员来管理。他的国家有n个城市,编号为1..n。一些城市之间有道路相连,任意两个不同的城市之间有且仅有一条直接或间接的道路。为了防止管理太过分散,每个省至少要有B个城市,为了能有效的管理,每个省最多只有3B个城市。每个省必须有一个省会,这个省会可以位于省内,也可以在该省外。但是该省的任意一个城市到达省会所经过的道路上的城市(除了最后一个城市,即该省省会)都必须属于该省。一个城市可以作为多个省的省会。聪明的你快帮帮这个国王吧!

Input

  第一行包含两个数N,B(1<=N<=1000, 1 <= B <= N)。接下来N-1行,每行描述一条边,包含两个数,即这条边连接的两个城市的编号。

Output

  如果无法满足国王的要求,输出0。否则输出数K,表示你给出的划分方案中省的个数,编号为1..K。第二行输出N个数,第I个数表示编号为I的城市属于的省的编号,第三行输出K个数,表示这K个省的省会的城市编号,如果有多种方案,你可以输出任意一种。

Sample Input

8 2 
1 2 
2 3 
1 8 
8 7 
8 6 
4 6 
6 5 

Sample Output

3 
2 1 1 3 3 3 3 2 
2 1 8 

题目分析

感觉分块方法好神啊
首先块的大小设为size 最后的块如果不足size和倒数第二块合在一起
然后把子树的点向栈内塞 大小达到size就是一块
可以研究一下块内都是连续的点的话怎么分

#include <cstdio>
#include <cstring>
#include <set>
#include <map>
#include <vector>
#include <cmath>
#include <queue>
#include <algorithm>
using namespace std;
int n,size,tot,top;
int head[1010],to[3000],net[3000];
int st[1010],root[1010],belong[1010];
void add(int x,int y)
{
    net[++tot]=head[x],head[x]=tot,to[tot]=y;
}
void dfs(int x,int temp)
{
    int tmp=top;
    for(int i=head[x];i;i=net[i])
    {
        if(to[i]==temp) continue;
        dfs(to[i],x);
        if(top-tmp>=size)
        {
            root[++root[0]]=x;
            while(top!=tmp) 
                belong[st[top--]]=root[0];
        }
    }
    st[++top]=x;
}
int main()
{
    scanf("%d%d",&n,&size);
    for(int x,y,i=1;i<n;i++)
        scanf("%d%d",&x,&y),add(x,y),add(y,x);
    dfs(1,0);
    while(top) belong[st[top--]]=root[0];
    printf("%d\n",root[0]);
    for(int i=1;i<=n;i++) printf("%d%c",belong[i],i!=n?' ':'\n');
    for(int i=1;i<=root[0];i++) printf("%d%c",root[i],i!=root[0]?' ':'\n'); 
    return 0;
}

发表评论

邮箱地址不会被公开。 必填项已用*标注