POJ3114 Countries in War

题目描述

Description

In the year 2050, after different attempts of the UN to maintain peace in the world, the third world war broke out. The importance of industrial, commercial and military secrets obliges all the countries to use extremely sophisticated espionage services, so that each city in the world has at least one spy of each country. These spies need to communicate with other spies, informers as well as their headquarters during their actions. Unluckily there doesn’t exist a secure way for a spy to communicate during the war period, therefore the messages are always sent in code so that only the addressee is able to read the message and understand its meaning.

The spies use the only service that functions during the war period, the post. Each city has a postal agency where the letters are sent. The letters can be sent directly to their destination or to other postal agencies, until the letter arrives at the postal agency of the destination city, if possible.

The postal agency in city A can send a printed letter to the postal agency in city B if there is an agreement on sending letters, which determines the time, in hours, that a letter takes to reach city B from city A (and not necessarily the opposite). If there is no agreement between the agencies A and B, the agency A can try to send the letter to any agency so that the letter can reach its destination as early as possible

Some agencies are connected with electronic communication media, such as satellites and optical fibers. Before the war, these connections could reach all the agencies, making that a letter could be sent instantly. But during the period of hostilities every country starts to control electronic communication and an agency can only send a letter to another agency by electronic media (or instantly) if they are in the same country. Two agencies, A and B, are in the same country if a printed letter sent from any one of the agencies can be delivered to the other one.

The espionage service of your country has managed to obtain the content of all the agreements on sending messages existing in the world and desires to find out the minimum time to send a letter between different pairs of cities. Are you capable of helping them?

Input

The input contains several test cases. The first line of each test case contains two integer separated by a space, N (1 ≤ N ≤ 500) and E (0 ≤ EN2), indicating the numbers of cities (numbered from 1 to N) and of agreements on sending messages, respectively. Following them, then, E lines, each containing three integers separated by spaces, X, Y and H (1 ≤ X, YN, 1 ≤ H ≤ 1000), indicating that there exist an agreement to send a printed letter from city X to city Y, and that such a letter will be delivered in H hours.

After that, there will be a line with an integer K (0 ≤ K ≤ 100), the number of queries. Finally, there will be K lines, each representing a query and containing two integers separated by a space, O and D (1 ≤ O, DN). You must determine the minimum time to send a letter from city O to city D.

The end of the input is indicated by N = 0.

Output

For each test case your program should produce K lines of output. The I-th line should contain an integer M, the minimum time, in hours, to send a letter in the I-th query. If there aren’t communication media between the cities of the query, you should print “Nao e possivel entregar a carta” (“It’s impossible to deliver the letter”).

Print a blank line after each test case.

Sample Input

4 5
1 2 5
2 1 10
3 4 8
4 3 7
2 3 6
5
1 2
1 3
1 4
4 3
4 1
3 3
1 2 10
2 3 1
3 2 1
3
1 3
3 1
3 2
0 0

Sample Output

0
6
6
0
Nao e possivel entregar a carta

10
Nao e possivel entregar a carta
0

题目分析:

题目大意:给出一些城市之间的有向路,如果两个城市间互相连通,则说明这两个城市属于同一国家,传递邮件不需要时间。不在同一国家则需要时间。给出一些询问,输出俩城市间的最短路,若不能到达,则输出那句英文。

先用Tarjan缩点,再Spfa.

#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <algorithm>
using namespace std;
int n,m;
int w[505][505];
int f[505][505];
int head[505];
int to[250005];
int val[250005];
int next[250005];
int deep[505];
int low[505];
int color,time;
bool vis[505];
int stack[505];
int belong[505];
int tot;
void init()
{
    color=0;
    time=0;tot=0;
    memset(vis,false,sizeof vis);
    memset(stack,0,sizeof stack);
    memset(low,0,sizeof low);
    memset(belong,0,sizeof belong);
    memset(deep,0,sizeof deep);
    memset(to,0,sizeof to);
    memset(val,0,sizeof val);
    memset(next,0,sizeof next);
    memset(head,0,sizeof head);
    memset(w,0x3f,sizeof w);
    memset(f,0x3f,sizeof f);
}
void add(int x,int y,int c)
{
    next[++tot]=head[x];
    to[tot]=y;
    val[tot]=c;
    head[x]=tot;
}
void tarjan(int x)
{
    deep[x]=low[x]=++time;
    stack[++stack[0]]=x;
    vis[x]=true;
    for(int i=head[x];i;i=next[i])
    {
        if(!deep[to[i]])
        {
            tarjan(to[i]);
            low[x]=min(low[x],low[to[i]]);
        }
        else if(vis[to[i]])
            low[x]=min(low[x],deep[to[i]]);
    }
    if(deep[x]==low[x])
    {
        color++;
        int tmp;
        do
        {
            tmp=stack[stack[0]--];
            belong[tmp]=color;
            vis[tmp]=false;
        }while(tmp!=x);
    }
}
bool visit[505];
int dis[505];
void spfa(int x)
{
    queue<int>q;
    q.push(x);
    memset(dis,0x3f,sizeof dis);
    memset(visit,false,sizeof visit);
    visit[x]=true;
    dis[x]=0;
    while(q.size())
    {
        int nmp=q.front();
        q.pop();
        visit[nmp]=false;
        for(int i=1;i<=color;i++)
            if(dis[i]>dis[nmp]+f[nmp][i])
            {
                dis[i]=dis[nmp]+f[nmp][i];
                if(!visit[i])
                {
                    visit[i]=true;
                    q.push(i);
                }
            }
    }
}
int main()
{
    while(scanf("%d%d",&n,&m)&&n!=0)
    {
        init();
        for(int i=1;i<=m;i++)
        {
            int x,y,c;
            scanf("%d%d%d",&x,&y,&c);
            add(x,y,c);
            w[x][y]=min(w[x][y],c);
        } 
        for(int i=1;i<=n;i++)
            if(!deep[i]) tarjan(i);
        for(int i=1;i<=n;i++) f[i][i]=0;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                if(i!=j&&(belong[i]!=belong[j]))
                    f[belong[i]][belong[j]]=min(f[belong[i]][belong[j]],w[i][j]);
        int k;
        scanf("%d",&k);
        for(int i=1;i<=k;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            if(belong[x]==belong[y])
                printf("0\n");
            else
            {
                spfa(belong[x]);
                if(dis[belong[y]]!=0x3f3f3f3f)
                    printf("%d\n",dis[belong[y]]);
                else printf("Nao e possivel entregar a carta\n");
            }
        } 
        printf("\n");
    }
    return 0;
}

发表评论

邮箱地址不会被公开。 必填项已用*标注