Description
给一个数字串s和正整数d, 统计s有多少种不同的排列能被d整除(可以有前导0)。例如123434有90种排列能
被2整除,其中末位为2的有30种,末位为4的有60种。
Input
输入第一行是一个整数T,表示测试数据的个数,以下每行一组s和d,中间用空格隔开。s保证只包含数字0, 1
, 2, 3, 4, 5, 6, 7, 8, 9.
Output
每个数据仅一行,表示能被d整除的排列的个数。
Sample Input
7
000 1
001 1
1234567890 1
123434 2
1234 7
12345 17
12345678 29
Sample Output
1
3
3628800
90
3
6
1398
HINT
在前三个例子中,排列分别有1, 3, 3628800种,它们都是1的倍数。
【限制】
100%的数据满足:s的长度不超过10, 1<=d<=1000, 1<=T<=15
题目分析
我错了,用STL水过了。next_permutation(a+1,a+len+1) 函数,自动生成下一个全排列,返回的是true/false
正解状压DP? 我一定学
#include <cstdio>
#include <cstring>
#include <set>
#include <map>
#include <vector>
#include <cmath>
#include <queue>
#include <algorithm>
using namespace std;
int t;
long long d;
int a[20];
char s[20];
void work()
{
scanf("%s%lld",&s[0],&d);
int len=strlen(s);
for(int i=1;i<=len;i++) a[i]=s[i-1]-'0';
long long ans=0;
sort(a+1,a+len+1);
do
{
long long tmp=0;
for(int i=1;i<=len;i++) tmp=tmp*10+a[i];
if(tmp%d==0) ans++;
}while(next_permutation(a+1,a+len+1));
printf("%lld\n",ans);
}
int main()
{
scanf("%d",&t);
while(t--) work();
return 0;
}