[BZOJ1179] [Apio2009] Atm

Description

Input

第一行包含两个整数N、M。N表示路口的个数,M表示道路条数。接下来M行,每行两个整数,这两个整数都在1到N之间,第i+1行的两个整数表示第i条道路的起点和终点的路口编号。接下来N行,每行一个整数,按顺序表示每个路口处的ATM机中的钱数。接下来一行包含两个整数S、P,S表示市中心的编号,也就是出发的路口。P表示酒吧数目。接下来的一行中有P个整数,表示P个有酒吧的路口的编号

Output

输出一个整数,表示Banditji从市中心开始到某个酒吧结束所能抢劫的最多的现金总数。

Sample Input

6 7
1 2
2 3
3 5
2 4
4 1
2 6
6 5
10
12
8
16
1 5
1 4
4
3
5
6

Sample Output

47

HINT

50%的输入保证N, M<=3000。所有的输入保证N, M<=500000。每个ATM机中可取的钱数为一个非负整数且不超过4000。输入数据保证你可以从市中心沿着Siruseri的单向的道路到达其中的至少一个酒吧。

题目分析:

tarjan缩点+spfa点权最长路 突然发现tarjan有点不会码了......

#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <algorithm>
using namespace std;
int n,m;
int deep[500100],low[500100],sta[500100],belong[500100],time,color;
bool vis[500100];
struct your
{
	int net[1000100],head[1000100],to[1000100],v[1000100];
	int tot;
	void add(int x,int y)
	{
		net[++tot]=head[x];
		to[tot]=y;
		head[x]=tot;
	}
}A,B;
void tarjan(int x)
{
	deep[x]=low[x]=++time;
	sta[++sta[0]]=x;
	vis[x]=true;
	for(int i=A.head[x];i;i=A.net[i])
	{
		if(!deep[A.to[i]])
		{
			tarjan(A.to[i]);
			low[x]=min(low[x],low[A.to[i]]);
			
		}
		else if(vis[A.to[i]])
			low[x]=min(low[x],deep[A.to[i]]);
	}
	if(deep[x]==low[x])
	{
		color++;
		int tmp;
		do
		{
			tmp=sta[sta[0]--];
			belong[tmp]=color;
			vis[tmp]=0;
			B.v[belong[tmp]]+=A.v[tmp];
		}while(tmp!=x);
	}
}
int s,p;
queue<int>q;
int dis[1000100];
void spfa(int x)
{
	q.push(x);
	dis[x]=B.v[x];
	memset(vis,0,sizeof vis);
	vis[x]=1;
	while(q.size())
	{
		int tmp=q.front();
		q.pop();
		vis[tmp]=0;
		for(int i=B.head[tmp];i;i=B.net[i])
			if(dis[B.to[i]]<dis[tmp]+B.v[B.to[i]])
			{
				dis[B.to[i]]=dis[tmp]+B.v[B.to[i]];
				if(!vis[B.to[i]])
					vis[B.to[i]]=1,q.push(B.to[i]);
			}
	}
}
int main()
{
	scanf("%d%d",&n,&m);
	for(int i=1;i<=m;i++)
	{
		int x,y;
		scanf("%d%d",&x,&y);
		A.add(x,y);
	}
	for(int i=1;i<=n;i++) scanf("%d",&A.v[i]);
	for(int i=1;i<=n;i++)
		if(!deep[i]) tarjan(i);
	for(int i=1;i<=n;i++)
		for(int j=A.head[i];j;j=A.net[j])
			if(belong[i]!=belong[A.to[j]])
				B.add(belong[i],belong[A.to[j]]);
	scanf("%d%d",&s,&p);
	spfa(belong[s]);
	int ans=0;
	for(int i=1;i<=p;i++)
	{
		int x;
		scanf("%d",&x);
		ans=max(ans,dis[belong[x]]);
	}
	printf("%d",ans);
 return 0;
}

发表评论

邮箱地址不会被公开。 必填项已用*标注